Project

General

Profile

Actions

Bug #31430

closed

Installer can't install the Ansible plugin on Debian/Ubuntu

Added by Evgeni Golov over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman modules
Target version:
-

Description

Ohai,

while playing with the idea in https://community.theforeman.org/t/testing-plugins-that-go-with-a-release/21475, I noticed that the Installer will fail trying to install the Ansible plugin on Debian/Ubuntu.

On Debian 10, the installer will fail with:

    2020-12-02 09:15:13 [ERROR ] [configure] Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install ansible-runner' returned 100: Reading package lists...
    2020-12-02 09:15:13 [ERROR ] [configure] Building dependency tree...
    2020-12-02 09:15:13 [ERROR ] [configure] Reading state information...
    2020-12-02 09:15:13 [ERROR ] [configure] E: Unable to locate package ansible-runner
    2020-12-02 09:15:13 [ERROR ] [configure] /Stage[main]/Foreman_proxy::Plugin::Ansible::Runner/Package[ansible-runner]/ensure: change from 'purged' to 'present' failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install ansible-runner' returned 100: Reading package lists...

This is because the repo we configure (https://releases.ansible.com/ansible-runner/deb/) doesn't carry packages for buster.

However, while it does carry packages for bionic (Ubuntu 18.04, which we also support), the installer installs the wrong GPG key (AC48AC71DA695CA15F2D39C4B84E339C442667A9 from https://releases.ansible.com/keys/RPM-GPG-KEY-ansible-release.pub), while the packages are signed with B719 6EFF 934F BC94 FBCD F40D D430 849D 3DD2 9021, so the installation will also fail there.


Related issues 2 (1 open1 closed)

Related to Installer - Bug #29359: ubuntu 16.04 and 18.04 NO_PUBKEY error on ansible-runner installationResolvedActions
Is duplicate of Installer - Bug #31226: ansible plugin installer - apt configuration error on debianNewActions
Actions #1

Updated by Ewoud Kohl van Wijngaarden over 3 years ago

I think this is a duplicate of #31226.

Actions #2

Updated by Ewoud Kohl van Wijngaarden over 3 years ago

  • Is duplicate of Bug #31226: ansible plugin installer - apt configuration error on debian added
Actions #3

Updated by Ewoud Kohl van Wijngaarden over 3 years ago

  • Related to Bug #29359: ubuntu 16.04 and 18.04 NO_PUBKEY error on ansible-runner installation added
Actions #4

Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Evgeni Golov
  • Pull request https://github.com/theforeman/puppet-foreman_proxy/pull/637 added
Actions #5

Updated by The Foreman Bot over 3 years ago

  • Fixed in Releases 2.4.0 added
Actions #6

Updated by Evgeni Golov over 3 years ago

  • Status changed from Ready For Testing to Closed
Actions #7

Updated by The Foreman Bot about 3 years ago

  • Pull request https://github.com/theforeman/puppet-foreman_proxy/pull/645 added
Actions #8

Updated by The Foreman Bot about 3 years ago

  • Pull request https://github.com/theforeman/puppet-foreman_proxy/pull/646 added
Actions #9

Updated by Ewoud Kohl van Wijngaarden about 3 years ago

  • Fixed in Releases 2.2.3, 2.3.3 added
Actions

Also available in: Atom PDF