Project

General

Profile

Bug #31452

Cannot build an EL 8.3 system via Satellite Bootdisk or Discovery kexec

Added by Lukas Zapletal about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Urgent
Category:
Templates
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Dracut in PXE images for RHEL 8.3 no longer accepts hardware type prefix in the BOOTIF kernel command line parameter. Foreman PXE/Grub2 templates adds BOOTIF with the prefix (e.g. BOOTIF=00-AA-BB-CC-DD-EE-FF) which leads to failure because NIC is not properly initialized. For PXELinux IPAPPEND 2 statement must be also removed because it automatically generates and appends BOOTIF statement with the prefix.

We need to implement a workaround in PXELinux, iPXE and Grub templates for this specifically for EL 8.3 or EL 8.3+ if this turns out to be expected behavior.


Related issues

Related to Foreman - Bug #31524: Do not put hardware type into BOOTIF configurable for EL8.3+Duplicate
Related to Foreman - Bug #31573: Drop IPAPPEND2 completely and use 01 for the hardware prefixClosed

Associated revisions

Revision f2c81699 (diff)
Added by Lukas Zapletal about 2 months ago

Fixes #31452 - BOOTIF workaround for EL 8.3

History

#1 Updated by Lukas Zapletal about 2 months ago

  • Bugzilla link set to 1903247

#2 Updated by The Foreman Bot about 2 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8179 added

#3 Updated by Tomer Brisker about 2 months ago

  • Target version set to 2.2.2

#4 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases 2.4.0 added

#5 Updated by Tomer Brisker about 2 months ago

  • Fixed in Releases 2.2.2, 2.3.1 added

#6 Updated by Lukas Zapletal about 2 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Lukas Zapletal about 1 month ago

  • Related to Bug #31524: Do not put hardware type into BOOTIF configurable for EL8.3+ added

#8 Updated by Lukas Zapletal 19 days ago

  • Related to Bug #31573: Drop IPAPPEND2 completely and use 01 for the hardware prefix added

Also available in: Atom PDF