Project

General

Profile

Bug #31536

'hammer host puppetrun' (deprecated) not marked as deprecated in hammer

Added by Dominik Matoulek 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Other commands
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1907807

Description of problem:
The puppetrun functionality was deprecated. However, hammer still shows original help for the puppetrun subcommand and 'not implemented' for invocation

How reproducible:
always

Steps to Reproduce:
1. # hammer host puppetrun --help
Usage:
hammer host puppetrun [OPTIONS]

Options:
--id ID
--location[-id|-title] Set the current location context for the request. Name/Title/Id can be used
--name NAME Name to search by
--organization[-id|-title] Set the current organization context for the request. Name/Title/Id can be used
-h, --help Print help

2. # hammer host puppetrun --organization-id 1 --location-id 1 --id 2
Error: 501 Not Implemented

Actual results:
1. shows original help
2. shows 'Not implemented'

Associated revisions

Revision d0be8147 (diff)
Added by Dominik Matoulek 3 months ago

fixes #31536 - Deprecating puppetrun command (#554)

Since the puppetrun is deprecated and removed, this PR making command deprecated

History

#1 Updated by Dominik Matoulek 4 months ago

  • Subject changed from 'hammer host puppetrun' (deprecated) not marked as deprecated in hammer to 'hammer host puppetrun' (deprecated) not marked as deprecated in hammer

#2 Updated by Dominik Matoulek 4 months ago

  • Triaged changed from No to Yes

#3 Updated by The Foreman Bot 4 months ago

  • Assignee set to Dominik Matoulek
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/554 added

#4 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases hammer-cli-foreman-2.4.0 added

#5 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Shira Maximov 3 months ago

  • Fixed in Releases hammer-cli-foreman-2.3.1 added

Also available in: Atom PDF