Project

General

Profile

Bug #31538

Each smart class parameter appears twice, when having two environments

Added by Andreas Haase 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Puppet integration
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

We have foreman 2.3.1 running, containing 2 environments. Each parameter of each puppet class is displayed twice. When trying to override the parameter in the corresponding tab in class view, we get the error "The class could not be saved because of an error in one of the class parameters".


Related issues

Related to Foreman - Refactor #29710: Change false where conditions to `none`Closed

Associated revisions

Revision e8a4bdd1 (diff)
Added by Tomer Brisker 9 months ago

Fixes #31538 - use `distinct` scope for class params association

Otherwise, classes with multiple environments load the paramters
multiple times. This is a regression caused by cleanup in cd4b1820.

History

#1 Updated by Tomer Brisker 9 months ago

  • Related to Refactor #29710: Change false where conditions to `none` added

#2 Updated by The Foreman Bot 9 months ago

  • Assignee set to Tomer Brisker
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8215 added

#3 Updated by Tomer Brisker 9 months ago

  • Target version set to 2.3.2
  • Category set to Puppet integration

#4 Updated by The Foreman Bot 9 months ago

  • Fixed in Releases 2.4.0 added

#5 Updated by Tomer Brisker 9 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Tomer Brisker 9 months ago

  • Fixed in Releases 2.3.2 added

#7 Updated by Tomer Brisker 9 months ago

  • Bugzilla link set to 1911641

Also available in: Atom PDF