Project

General

Profile

Feature #31564

Jobs email notification with jobs screenshot

Added by masadrasheed please_edit_me over 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

user can get email if jobs completed with image attachment.
Also he can select users which can get emails regarding job completion.

Associated revisions

Revision a6a16675 (diff)
Added by Marek Hulán 11 months ago

Fixes #31564 - add email notification

User can subscribe to either all job notifications, successful jobs or
failed jobs or no notifications. The user who runs the job would then be
notified based on the subscription. It supports both plain text and html
emails.

Since now we have a way to run the notification even on failure, the
notification drawer notification has been also added in case the job
fails.

History

#1 Updated by Adam Ruzicka over 1 year ago

With screenshot of what exactly?

#2 Updated by Marek Hulán over 1 year ago

Originally reported here https://community.theforeman.org/t/jobs-email-notification/21753

The problem is we have only notificatio drawer notifications for jobs, no email notifications (which we have for everything else)

#3 Updated by Marek Hulán over 1 year ago

I actually vote for this feature too, I just realized my job that runs on daily basis is failing for 12 days already. Without actively checking the Foreman UI, I wouldn't notice that.

#4 Updated by The Foreman Bot about 1 year ago

  • Assignee set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_remote_execution/pull/638 added

#5 Updated by Marek Hulán 11 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Adam Ruzicka 11 months ago

  • Fixed in Releases foreman_remote_execution-4.8.0 added

Also available in: Atom PDF