Project

General

Profile

Bug #31573

Drop IPAPPEND2 completely and use 01 for the hardware prefix

Added by Lukas Zapletal 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Templates
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Due to regression in EL 8.3 dracut/nm it no longer accepts 00 as hardware type. However 01 (ethernet) is accepted. A temporary fix was made in #31452 to workaround the issue, now NetworkManger is getting a fix to accept both 01 and 00 the final solution is simply to default to the correct hardware type 01 alltogether and removing IPAPPEND 2 statement because it was unnecessary anyway (BOOTIF was actually twice).

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/merge_requests/713


Related issues

Related to Foreman - Bug #31452: Cannot build an EL 8.3 system via Satellite Bootdisk or Discovery kexecClosed
Related to Foreman - Bug #31524: Do not put hardware type into BOOTIF configurable for EL8.3+Duplicate

Associated revisions

Revision 789225c2 (diff)
Added by Lukas Zapletal 3 months ago

Fixes #31573 - drop IPAPPEND2 and use BOOTIF with 01 prefix

History

#1 Updated by Lukas Zapletal 4 months ago

  • Related to Bug #31452: Cannot build an EL 8.3 system via Satellite Bootdisk or Discovery kexec added

#2 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8230 added

#3 Updated by Lukas Zapletal 4 months ago

  • Related to Bug #31524: Do not put hardware type into BOOTIF configurable for EL8.3+ added

#4 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 2.4.0 added

#5 Updated by Lukas Zapletal 3 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman/pull/8286 added

#7 Updated by Lukas Zapletal 3 months ago

  • Target version set to 2.3.3

Requesting 2.3.

In order to be able to provision EL 8.4 and later, this fix is needed for the final solution to the problem. This was delayed due to longer discussion with Anaconda/NM team on how to approach this.

#8 Updated by Tomer Brisker 3 months ago

  • Fixed in Releases 2.3.3 added

Also available in: Atom PDF