Project

General

Profile

Bug #31586

creating a puppet repo with pulp3 installed but not running results in ' A capsule seems to have been refreshed without pulpcore being running. You may want to'

Added by Justin Sherrill over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Repositories
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

This happens if pulp3 is installed, but pulp2 is set to be used, the pulp3 smart proxy feature has no capabilities, and you try to create a puppet repo

Associated revisions

Revision b6532ce6 (diff)
Added by Justin Sherrill over 1 year ago

Fixes #31586 - use pulp2 if pulp3 does not support a type

Revision ac346f38 (diff)
Added by Evgeni Golov over 1 year ago

Refs #31586 - load common.rake for pulp3 content switchover

in b6532ce we added disable_dynflow to the switchover task, but didn't
load the common.rake that defines it.

History

#1 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9093 added

#2 Updated by Justin Sherrill over 1 year ago

  • Target version set to Katello 3.18.2

#3 Updated by Justin Sherrill over 1 year ago

  • Target version changed from Katello 3.18.2 to Katello 3.17.2

#4 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.1.0 added

#5 Updated by Justin Sherrill over 1 year ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Justin Sherrill over 1 year ago

  • Bugzilla link set to 1914359

#7 Updated by The Foreman Bot over 1 year ago

  • Pull request https://github.com/Katello/katello/pull/9098 added

#8 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes

Also available in: Atom PDF