Project

General

Profile

Bug #31612

Module stream filtering not working for certain repositories

Added by Ian Ballou over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Module stream filtering is failing for certain repositories. The earliest I've checked this bug is Katello 3.17.1. It also occurs with the latest dev code.

Failing:
- Katello's local "zoo" repository under test/fixtures/test_repos/zoo
- https://fixtures.pulpproject.org/rpm-with-modules/

Working:
- https://partha.fedorapeople.org/test-repos/separated/modules-rpms/


Related issues

Is duplicate of Katello - Feature #31785: Upgrade pulp-rpm to 3.9 for master, 4.0Closed

History

#1 Updated by Ian Ballou over 1 year ago

To be clear, this is with Pulp 3.

#2 Updated by Ian Ballou over 1 year ago

I tested again with Katello 3.16 and it worked then.

#3 Updated by Ian Ballou over 1 year ago

It's looking like it's not confined to module streams. RPM packages are not filtering for the repos in question as well.

#4 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes

#5 Updated by Ian Ballou over 1 year ago

#6 Updated by Chris Roberts over 1 year ago

  • Target version changed from Katello 3.17.2 to Katello 3.17.3

#7 Updated by Ian Ballou over 1 year ago

  • Target version changed from Katello 3.17.3 to Katello Recycle Bin
  • Status changed from New to Duplicate

Marking as a duplicate on #31785 because the issue was fixed completely on the Pulp 3 side of things. Upgrading to pulp-rpm 3.9 will fix the issue.

#8 Updated by Ian Ballou over 1 year ago

  • Is duplicate of Feature #31785: Upgrade pulp-rpm to 3.9 for master, 4.0 added

Also available in: Atom PDF