Project

General

Profile

Bug #3167

gettext_i18n_rails 1.0.0 incompatible with gettext 2.x

Added by Dominic Cleal almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Immediate
Category:
Packaging
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

gettext_i18n_rails 1.0.0 was released on Sept 30th, which requires gettext 3.0.2 or higher.

https://github.com/grosser/gettext_i18n_rails/commit/d1b02f734f9e0c96de50d1a58e8170ce6ec457ac
https://github.com/grosser/gettext_i18n_rails/commit/6c83ce9255122ddb0c28ec5ca96e5a1975a8e0c8

Via #3005, we've restricted gettext to 2.x to retain Ruby 1.8 compatibility, so we also need to pin gettext_i18n_rails to ~> 0.8.

no such file to load -- gettext/tools/task
/usr/local/rvm/gems/ruby-1.8.7-p371@test_develop_pull_request-2/gems/activesupport-3.2.14/lib/active_support/dependencies.rb:251:in `require'
/usr/local/rvm/gems/ruby-1.8.7-p371@test_develop_pull_request-2/gems/activesupport-3.2.14/lib/active_support/dependencies.rb:251:in `require'
/usr/local/rvm/gems/ruby-1.8.7-p371@test_develop_pull_request-2/gems/activesupport-3.2.14/lib/active_support/dependencies.rb:236:in `load_dependency'
/usr/local/rvm/gems/ruby-1.8.7-p371@test_develop_pull_request-2/gems/activesupport-3.2.14/lib/active_support/dependencies.rb:251:in `require'
/usr/local/rvm/gems/ruby-1.8.7-p371@test_develop_pull_request-2/gems/gettext_i18n_rails-1.0.0/lib/gettext_i18n_rails/tasks.rb:1

Related issues

Related to Foreman - Tracker #4656: Drop Ruby 1.8 supportClosed

Associated revisions

Revision a503cfce (diff)
Added by Lukas Zapletal almost 6 years ago

fixes #3167 - downgrade gettext_i18n_rails for gettext / 1.8 compat

Revision c4c4979b (diff)
Added by Lukas Zapletal almost 6 years ago

fixes #3167 - downgrade gettext_i18n_rails for gettext / 1.8 compat

(cherry picked from commit a503cfce76fe710e4a13de7a487a359164479d53)

Conflicts:
bundler.d/i18n.rb
foreman.spec

Revision 0ae9a632 (diff)
Added by Lukas Zapletal almost 6 years ago

fixes #3167 - downgrade gettext_i18n_rails for gettext / 1.8 compat

(cherry picked from commit a503cfce76fe710e4a13de7a487a359164479d53)

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Related to Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final added

#2 Updated by Dominic Cleal almost 6 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Lukas Zapletal

#3 Updated by Lukas Zapletal almost 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Lukas Zapletal almost 6 years ago

  • Related to deleted (Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final)

#5 Updated by Dominic Cleal over 5 years ago

Also available in: Atom PDF