Project

General

Profile

Bug #31875

Disable/ Work around deb migration before upgrading if there's no debian content

Added by Samir Jha over 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

We don't support debian content migration yet but this stop content-switchover for users with deb enabled even if they don't have any debian content. We should have an option to work around this.

More context: https://community.theforeman.org/t/pulp-2-to-pulp3-upgrade-fails/22190/6


Related issues

Has duplicate Katello - Bug #31941: Pulp migration switchover: cannot find repo type error when repo type disabled but repo type is set to use Pulp 2Duplicate

History

#1 Updated by John Mitsch over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.3

#2 Updated by Ian Ballou about 1 year ago

The katello_debs table also seems to be missing the migrated_pulp3_href column:

PG::UndefinedColumn: ERROR:  column katello_debs.migrated_pulp3_href does not exist
LINE 1: SELECT COUNT(*) FROM "katello_debs" WHERE "katello_debs"."mi...

I'm able to always reproduce this on 3.18 if deb is enabled.

#3 Updated by Ian Ballou about 1 year ago

The workaround I found is to disable deb entirely: foreman-installer --katello-use-pulp-2-for-deb=false --katello-enable-deb=false

#4 Updated by Justin Sherrill about 1 year ago

  • Has duplicate Bug #31941: Pulp migration switchover: cannot find repo type error when repo type disabled but repo type is set to use Pulp 2 added

#5 Updated by Justin Sherrill about 1 year ago

  • Status changed from New to Rejected

rejecting in favor of 32420

#6 Updated by Jonathon Turel about 1 year ago

  • Target version changed from Katello 3.18.3 to Katello Recycle Bin

Also available in: Atom PDF