Project

General

Profile

Feature #31885

Feature #30440: Simple & automatic host registration WF

Feature #31807: Host Registration - UI Form improvements

Global Registration: page does not pre-populate values for "Setup Insights" & "Remote Execution" from Global Parameters

Added by Leos Stejskal 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host registration
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1919958

Description of problem:
Global Registration Page does not populate values for "Setup Insights" & "Remote Execution" from Global Parameters.

In satellite 6.9 we have added 2 new Global Parameters host_registration_insights & host_registration_remote_execution that are used on the Global Registration page as a default value, but we are not pre-populating its values from Global Parameters.

Customers will not refer to the Global Parameters page very often so we should populate its values on the Global Registration page.

Version-Release number of selected component (if applicable):
Satellite 6.9

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Hosts -> All Hosts -> Register Host
2. Check for the Setup Insights & Remote Execution settings which does not have pre-populated values but it considers these values in the backend.
3.

Associated revisions

Revision 7212bd76 (diff)
Added by Leos Stejskal 7 months ago

Fixes #31885 - Registration - Simplified logic for rex & insights (#8342)

- New options in form for rex & insights: keep default value (inherit from parameter) or override (enforcement of yes or no).
- Showing the current value of rex & insights parameters is not possible, since it can be overriden on OS/host group/organization/location level, this will be enhanced later with the new implementation of the form.

History

#1 Updated by Leos Stejskal 7 months ago

  • Parent task set to #31807
  • Assignee set to Leos Stejskal
  • Category set to Host registration

#2 Updated by The Foreman Bot 7 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8342 added

#3 Updated by The Foreman Bot 7 months ago

  • Fixed in Releases 2.5.0 added

#4 Updated by Leos Stejskal 7 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF