Project

General

Profile

Bug #31941

Pulp migration switchover: cannot find repo type error when repo type disabled but repo type is set to use Pulp 2

Added by Ian Ballou about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

A user on Katello 3.18 disabled the deb content type and the switchover failed since it was still true under use_pulp_2_for_content_type. Here's the error: `error (RuntimeError): Cannot find repository type deb, is it enabled?`.

To fix this, we should probably check if a content type is enabled before checking if it's set to use Pulp 2.


Related issues

Is duplicate of Katello - Bug #31875: Disable/ Work around deb migration before upgrading if there's no debian contentRejected

History

#2 Updated by Jonathon Turel about 1 year ago

  • Triaged changed from No to Yes
  • Category set to Repositories

#3 Updated by Justin Sherrill about 1 year ago

  • Is duplicate of Bug #31875: Disable/ Work around deb migration before upgrading if there's no debian content added

#4 Updated by Justin Sherrill about 1 year ago

  • Status changed from New to Duplicate

#5 Updated by Jonathon Turel about 1 year ago

  • Target version changed from Katello 3.18.3 to Katello Recycle Bin

Also available in: Atom PDF