Project

General

Profile

Bug #32046

Cannot set setting value to empty for settings with selection

Added by Ondřej Pražák 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Settings
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

1. Create a Http Proxy (Go to Infrastructure > Http Proxies)
2. Go to Administer > Settings > Content tab
3. Set "Default HTTP Proxy"
4. Now try to set "Default HTTP Proxy" to "no global default".

Actual results:
Oh no! Something went wrong while submitting the form, the server returned the following error: There is no such HTTP Proxy

Also reproducible with host_owner setting in provisioning category.


Related issues

Related to Foreman - Bug #31603: Settings "Content" page disappeared after setting the http-proxy.Closed

Associated revisions

Revision 105e3e10 (diff)
Added by Ondřej Pražák 5 months ago

Fixes #32046 - Set setting with selection to empty value

History

#1 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8372 added

#2 Updated by Ondřej Pražák 5 months ago

  • Related to Bug #31603: Settings "Content" page disappeared after setting the http-proxy. added

#3 Updated by Tomer Brisker 5 months ago

  • Bugzilla link set to 1918167

#4 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 2.5.0 added

#5 Updated by Ondřej Pražák 5 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by The Foreman Bot 5 months ago

  • Pull request https://github.com/theforeman/foreman/pull/8380 added

#7 Updated by Tomer Brisker 5 months ago

  • Fixed in Releases 2.4.0 added
  • Fixed in Releases deleted (2.5.0)

#8 Updated by Tomer Brisker 5 months ago

  • Category set to Settings
  • Fixed in Releases 2.3.4 added

Also available in: Atom PDF