Project

General

Profile

Bug #32153

"Deselect all" tooltip does not hide after click

Added by Adi Abramovitch 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
easy
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Reproduce:
1. Create a new organization
2. Press submit
3. Deselect all in "Provisioning Templates"
4. Try to Deselect all in "Partition Tables"and the message will appear

Associated revisions

Revision d3ddfac0 (diff)
Added by Tomer Brisker 3 months ago

Fixes #32153 - Hide tooltip on multiselect all buttons

The tooltips remain shown on click because the elemnt they are attached
to is a `a` tag, which remains in focus until the user clicks elsewhere
so there is no `focusout` event fired.
For the deselect all button, the click handler calls
`multiSelect('refresh')` which in turn removes the multiselect element
(with the tooltip event handlers) from the DOM1, leaving the tooltip
always displayed.
Since we only use tooltips for hover help, the `focus` trigger has been
removed. Popovers should be used when showing information that is
displayed on focus (i.e. when clicking on an element).

[1] https://github.com/lou/multi-select/blob/0.9.12/js/jquery.multi-select.js#L335

History

#1 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8428 added

#2 Updated by Tomer Brisker 3 months ago

  • Assignee deleted (Adi Abramovitch)
  • Category deleted (Web Interface)
  • Subject changed from message "Deselect all" appears when moving to a different page to "Deselect all" tooltip does not hide after click

Note: this is true for any multiselect box, the tooltips for deselect aren't hideable.

#3 Updated by Tomer Brisker 3 months ago

  • Assignee set to Tomer Brisker
  • Category set to Web Interface

#4 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 2.5.0 added

#5 Updated by Tomer Brisker 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF