Project

General

Profile

Actions

Feature #32158

closed

Allow 'feature' option when invoking a job

Added by Jonathon Turel over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Today it's required to first look up a job template ID before being able to use that job template via `hammer job-invocation create`

Today

hammer job-invocation create --job-template-id 150 --search-query='host.example.com' --inputs 'package=vim'

Desired

hammer job-invocation create --feature=katello_package_install --search-query='host.example.com' --inputs 'package=vim'

This makes the process one step and users can start to become familiar with the particular feature names which (ideally) are named well enough to be guessable similar to 'hammer host package install'


Related issues 3 (0 open3 closed)

Is duplicate of Foreman Remote Execution - Feature #32107: Hammer job invocation creation does not allow to use --feature for the job template lookupClosedJonathon TurelActions
Blocks Katello - Tracker #32155: Deprecate agent-based APIs and Hammer commandsClosedJonathon Turel

Actions
Blocks Katello - Feature #32157: Deprecate agent-based Hammer commandsClosedJonathon TurelActions
Actions #1

Updated by Jonathon Turel over 3 years ago

  • Blocks Tracker #32155: Deprecate agent-based APIs and Hammer commands added
Actions #2

Updated by Jonathon Turel over 3 years ago

Actions #3

Updated by Adam Ruzicka over 3 years ago

  • Is duplicate of Feature #32107: Hammer job invocation creation does not allow to use --feature for the job template lookup added
Actions #4

Updated by Jonathon Turel about 3 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF