Project

General

Profile

Feature #32175

By default, do not backup tasks when cleaning them up

Added by Eric Helms 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Associated revisions

Revision f69c9f1b (diff)
Added by Eric Helms 6 months ago

Fixes #32175: Allow toggling task backup when cleaning them up

Changes the default behavior to disable task backup when enabling
the task cleanup cron job. Users who still want backups kept
on disk will need to set the parameter to true.

Revision 2367fd7f (diff)
Added by Eric Helms 6 months ago

Refs #32175: Set foreman-tasks backup to true on upgrades

For new installations, the intent is to default to task cleanup
to not store backups of the tasks deleted. Since the previous
behavior is to store backups on cleanup, when upgrading users
should retain the same behavior and intentionally disable backups
to prevent unexpected behavior changes.

History

#1 Updated by The Foreman Bot 6 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-foreman/pull/922 added

#2 Updated by The Foreman Bot 6 months ago

  • Pull request https://github.com/theforeman/foreman-installer/pull/664 added

#3 Updated by The Foreman Bot 6 months ago

  • Fixed in Releases 2.5.0 added

#4 Updated by Eric Helms 6 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF