Project

General

Profile

Bug #32232

Package matching query does not exist when syncing TimeScaleDB repo after migration

Added by Ian Ballou over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1944812

Syncing https://packagecloud.io/timescale/timescaledb/el/7/x86_64 or https://packagecloud.io/timescale/timescaledb/el/8/x86_64 with Pulp 2 and then migrating causes the next sync to fail for those two repositories. Tested on Katello 3.18.1 and Katello 3.18.2.

---
pulp_tasks:
- pulp_href: "/pulp/api/v3/tasks/afed94a5-e893-4140-8712-85c248359961/"
pulp_created: '2021-03-25T15:18:24.485+00:00'
state: failed
name: pulp_rpm.app.tasks.synchronizing.synchronize
started_at: '2021-03-25T15:18:24.611+00:00'
finished_at: '2021-03-25T15:18:28.367+00:00'
error:
traceback: |2
File "/usr/lib/python3.6/site-packages/rq/worker.py", line 936, in perform_job
rv = job.perform()
File "/usr/lib/python3.6/site-packages/rq/job.py", line 684, in perform
self._result = self._execute()
File "/usr/lib/python3.6/site-packages/rq/job.py", line 690, in _execute
return self.func(*self.args, **self.kwargs)
File "/usr/lib/python3.6/site-packages/pulp_rpm/app/tasks/synchronizing.py", line 266, in synchronize
dv.create()
File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/declarative_version.py", line 148, in create
loop.run_until_complete(pipeline)
File "/usr/lib64/python3.6/asyncio/base_events.py", line 484, in run_until_complete
return future.result()
File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/api.py", line 225, in create_pipeline
await asyncio.gather(*futures)
File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/api.py", line 43, in call
await self.run()
File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/content_stages.py", line 105, in run
d_content.content.q()
File "/usr/lib/python3.6/site-packages/django/db/models/manager.py", line 82, in manager_method
return getattr(self.get_queryset(), name)(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/django/db/models/query.py", line 408, in get
self.model._meta.object_name
description: Package matching query does not exist.
worker: "/pulp/api/v3/workers/135dc424-94fb-4e18-9fc6-c6549530c8cd/"
child_tasks: []
progress_reports:
- message: Parsed Packages
code: parsing.packages
state: completed
total: 199
done: 199
- message: Downloading Metadata Files
code: downloading.metadata
state: completed
done: 4
- message: Downloading Artifacts
code: downloading.artifacts
state: completed
done: 0
- message: Associating Content
code: associating.content
state: canceled
done: 0
- message: Un-Associating Content
code: unassociating.content
state: canceled
done: 0
created_resources: []
reserved_resources_record:
- "/pulp/api/v3/repositories/rpm/rpm/15bb570c-705c-46e2-bae5-8e3b41cfb583/"
- "/pulp/api/v3/remotes/rpm/rpm/6144e1fc-7b8e-489c-9517-46fd02472156/"
create_version: true
task_groups: []
poll_attempts:
total: 6
failed: 1


Related issues

Related to Katello - Bug #32301: Update pulp-rpm to 3.10.0 for Katello 3.18.Closed

Associated revisions

Revision f7bef07a (diff)
Added by Ian Ballou over 1 year ago

Fixes #32232 - Package matching query issue w/ TimeScale DB (upgrade to pulp-rpm 3.10) (#9271)

History

#1 Updated by Ian Ballou over 1 year ago

  • Subject changed from Package matching query does not exist when syncing TimeScaleDB repo after migration to Package matching query does not exist when syncing TimeScaleDB repo after migration
  • Found in Releases Katello 3.18.1, Katello 3.18.2, Katello 3.18.2.1 added

#2 Updated by Ian Ballou over 1 year ago

The fix for this will be to backport pulp-rpm 3.10 into Katello 3.18 after master gets pulpcore 3.11 and pulp-rpm 3.10.

#3 Updated by Justin Sherrill over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.3

Putting on 3.18.3 to get pulp-rpm 3.10 into 3.18

#4 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Ian Ballou
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9271 added

#5 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.2.0 added

#6 Updated by Anonymous over 1 year ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Ian Ballou over 1 year ago

  • Related to Bug #32301: Update pulp-rpm to 3.10.0 for Katello 3.18. added

#8 Updated by Ian Ballou over 1 year ago

  • Target version changed from Katello 3.18.3 to Katello 4.0.1

re-triaging to a later release since #32301 will take care of the 3.18 CP.

#9 Updated by Ian Ballou over 1 year ago

  • Target version changed from Katello 4.0.1 to Katello 4.1.0

re-triaging to a later release since #32301 will take care of the 3.18 CP.

Also available in: Atom PDF