Project

General

Profile

Actions

Bug #32359

closed

Hammer Report-Template Complains about 'Input Days from Now' Being Blank

Added by Oleh Fedorenko about 3 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Reporting
Target version:
-
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1943306

Description of problem:

This seems like a regression from earlier versions of Satellite. Trying to generate a Subscription - Entitlement Report throws an error about Input Days from Now. Earlier versions of Satellite (6.6, 6.7) did not show this issue:

~~~
  1. hammer report-template list | grep 130
    130 | Subscription - Entitlement Report
  1. hammer report-template generate --report-format yaml --id 130

Input Days from Now: Value can't be blank
Input Days from Now: Value is not included in the list
~~~

Adding the "--inputs" flag with a value works:

~~~
  1. hammer report-template generate --report-format yaml --id 130 --inputs "Days from Now"="no limit"
    ~~~

Version-Release number of selected component (if applicable):
Satellite 6.8.2

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
report template fails to run due to error about "Days from Now"

Expected results:
report template should generate without warning

Additional info:

Actions #1

Updated by Oleh Fedorenko about 3 years ago

  • Category changed from Statistics to Reporting
  • Priority changed from High to Normal
  • Difficulty set to easy
  • Triaged changed from No to Yes

The error also appears when using API directly. I'd suggest allow nil or use default value for "Input Days from Now" input.

Actions #2

Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9942 added
Actions #3

Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 3.10.0 added
Actions #4

Updated by Quinn James 5 months ago

  • Status changed from Ready For Testing to Closed
Actions #5

Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman/pull/10005 added
Actions

Also available in: Atom PDF