Project

General

Profile

Feature #32374

The smart proxy services entry for Pulpcore displays a VERY misleading version

Added by Quirin Pamp about 1 year ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

This issue relates to https://github.com/theforeman/smart_proxy_pulp

When navigating to "Infrastructure > Smart Proxies > <any_smart_proxy_from_the_list> > Services tab", we see a block for Pulp and Pulpcore (provided those features are installed).

For the "Pulp" feature (Pulp 2) the block lists both "Version" and "Pulp server version", which makes it relatively clear that "Version" is the version of the gem providing the "Pulp" smart proxy feature.

For the "Pulpcore" feature (Pulp 3) the block just lists "Version" (that is the version of the smart_proxy_pulp ruby gem). However, "Pulpcore: Version: <not_the_pulpcore_version>" is a super misleading way to display things.

Users expect this to be the version of pulpcore and not the version of the smrat proxy component that speaks to pulpcore: https://community.theforeman.org/t/which-pulp-version-is-running/23229

This could easily be mitigated by adding the pulpcore version similar to the Pulp 2 case. In addition prominently displaying what pulpcore version people are using makes a lot of sense for bug reports and trouble shooting.

smart_proxy_pulp_services.png View smart_proxy_pulp_services.png 44.6 KB Quirin Pamp, 04/21/2021 12:27 PM
Smart proxy pulp services

Related issues

Is duplicate of Katello - Bug #33211: incorrect pulp version number after upgrade to pulp 3Closed

History

#1 Updated by Quirin Pamp about 1 year ago

  • Found in Releases Katello 3.18.0 added

#2 Updated by Samir Jha about 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.2.0

#3 Updated by Justin Sherrill 9 months ago

  • Is duplicate of Bug #33211: incorrect pulp version number after upgrade to pulp 3 added

#4 Updated by Justin Sherrill 9 months ago

  • Target version changed from Katello 4.2.0 to Katello Recycle Bin
  • Status changed from New to Duplicate

Also available in: Atom PDF