Project

General

Profile

Bug #32394

@grub_pass seems deprecated in the default kickstart template

Added by Oleh Fedorenko 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Templates
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1931316

Description of problem:

We have this in the default kickstart template:

bootloader --location=mbr --append="<%= host_param('bootloader-append') || 'nofb quiet splash=quiet' %>" <%= @grub_pass %>

According to https://community.theforeman.org/t/grub-pass-ks-console/10610, @grub_pass is defined nowhere and the code is dead. Thus, we should change the template to use @host.grub_pass so that people can define grub_grass as a host/hg/global param.

Version-Release number of selected component (if applicable):

6.8

How reproducible:

Easy

Steps to Reproduce:
1. nowhere to define @grub_pass. The only way to change the booloader password is to clone the template. However, in same cases, people do not want to clone.

Actual results:

Can not define @grub_pass to pass the bootloader password

Expected results:

Can define @grub_pass to pass the password.

Associated revisions

Revision e9a52589 (diff)
Added by Oleh Fedorenko 5 months ago

Fixes #32394 - Use grub_pass macro instead of variable

The default Kickstart template uses obsolete @grub_pass variable
which are not being set anywhere. Maybe it's due to typo or else.
I suggest to use macro instead so it's possible to set the password
via host params and do not clone the template for this purpose only.

History

#1 Updated by Oleh Fedorenko 5 months ago

  • Triaged changed from No to Yes
  • Assignee set to Oleh Fedorenko
  • Status changed from New to Assigned
  • Category changed from TFTP to Templates

#2 Updated by The Foreman Bot 5 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8461 added

#3 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 2.5.0 added

#4 Updated by Oleh Fedorenko 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF