Project

General

Profile

Bug #32397

Confirming interface modal by enter causes whole Host form to get confirmed

Added by Ondřej Ezr 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Host creation
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

If interface modal (in edit host menu) is confirmed with enter, enter confirms host update instead of new interface, this action cause another misbehavior

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1775784

Description of problem:
When user adds new interfaces to hosts and user will confirm this action with enter instead new interface confirmation the host update confirmation is done. This action is also causing additional bug where user is unable to continue with his work without refresh or url change, because screen is faded with gray color and no action is allowed.

Version-Release number of selected component (if applicable):
Sat 6.6 snap 24
and also
Sat 6.7 snap 1

How reproducible:
Always

Steps to Reproduce:
1. Navigate through Host -> Edit host -> Interfaces -> Add Interface
2. Click with mouse to any field in Add interface menu ( e.g Device Identifier)
3. Press Enter on your keyboard (doesn't matter which enter)

Actual results:
Confirmation doesn't work for new interface submit, but for the host submit. Host is updated, but user is unable to continue the work, because screen is faded by gray color.

more concretely div element with class: modal-backdrop fade in

Expected results:
After user will hit the enter, only new interface should be added. And another enter should confirm host update.

Additional info:
Not sure why is allowed to add empty interfaces ( without any attributes ) to your hosts. But this is not connected with this bugzilla. I would just like to know the idea behind that.

Associated revisions

Revision 71a331c5 (diff)
Added by Adi Abramovitch 2 months ago

Fixes #32397 - changed button type to submit (#8543)

`<input type="button">` doesn't get the enter event in some cases.
submit type with `return false;` should fix this issue.

History

#1 Updated by Adi Abramovitch 3 months ago

  • Triaged changed from No to Yes
  • Assignee set to Adi Abramovitch
  • Subject changed from Confirming interface modal by enter causes whole Host form to get confirmed to Confirming interface modal by enter causes whole Host form to get confirmed

#2 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8543 added

#3 Updated by The Foreman Bot 2 months ago

  • Fixed in Releases 3.0.0 added

#4 Updated by Anonymous 2 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Tomer Brisker about 2 months ago

  • Target version set to 2.5.1

#6 Updated by The Foreman Bot about 2 months ago

  • Pull request https://github.com/theforeman/foreman/pull/8590 added

#7 Updated by Tomer Brisker about 2 months ago

  • Category changed from Inventory to Host creation
  • Fixed in Releases 2.5.1 added

Also available in: Atom PDF