Project

General

Profile

Bug #32433

Upgrade from 4.0 to 4.1(nightly) fails due to md5 content being enabled in 4.0

Added by Evgeni Golov about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Upgrades
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When one upgrades a 4.0 to nightly, the installer will fail to call pulpcore-manager --collectstatic, as the latter errors out with:

django.core.exceptions.ImproperlyConfigured: There have been identified artifacts with forbidden checksum 'md5'. Run 'pulpcore-manager handle-artifact-checksums' first to unset forbidden checksums.

This needs to be handled nice(ly/r)? :)


Related issues

Is duplicate of Installer - Bug #32443: support md5 checksums for pulpcore_allowed_content_checksums to better support upgradesClosed

History

#1 Updated by Justin Sherrill about 1 year ago

  • Status changed from New to Rejected

#2 Updated by Justin Sherrill about 1 year ago

  • Target version set to Katello Recycle Bin

#3 Updated by Justin Sherrill about 1 year ago

  • Is duplicate of Bug #32443: support md5 checksums for pulpcore_allowed_content_checksums to better support upgrades added

Also available in: Atom PDF