Project

General

Profile

Bug #32437

Webpack-dev-server doesn't support http2

Added by Ron Lavi 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Development tools
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The issue is that node v10+ doesn't support spdy,
and it's not possible in webpack-dev-server v2 the pass the correct option in order to disable h2,
on newer webpack-dev-server versions this issue is resolved

Associated revisions

Revision f5a3dd2d (diff)
Added by Ron Lavi 3 months ago

Fixes #32437 - Use webpack-dev-server-without-h2

Looks like webpack-dev-server version 2.x
can't support https without http2 due to missing options
when using command line parameters,
this is an hack that will prevent manually removing a line
after each `npm install` and will give us some air
while trying to upgrade to webpack 5.

History

#1 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8475 added

#2 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 3.0.0 added

#3 Updated by Ron Lavi 3 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Tomer Brisker 3 months ago

  • Category set to Development tools

Also available in: Atom PDF