Project

General

Profile

Bug #32497

kickstart_kernel_options doesn't handle properly tagged vlan over bond device

Added by Joniel Pasqualetto 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Templates
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:

When a host to be provisioned has a virtual interface that requires a VLAN tag and is attached to a bond device, the kernel options simply ignore the bond device, creating only the VLAN. Therefore, dracut does not get configured properly and provisioning fails.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create a new host
2. Add 2 physical interfaces and mark both only as "managed"
3. Add a bond device using the 2 physical interfaces. Mark only the option "managed" to this interface too
4. Create a virtual interface, set a vlan tag and put the bond a master interface
5. Look at the rendered template "PXEGrub template" for example. You'll see something like this (pasting only the part of the line that

~~~
(...)

... network ksdevice=bootif ks.device=bootif kssendmac ks.sendmac inst.ks.sendmac ip=192.168.250.81::192.168.250.1:255.255.255.0:ryan-blacher.example.local:vlan409:none nameserver=192.168.250.100 vlan=vlan409:bond0
~~~

Note that the vlan is defined and it points to the device "bond0", but the bond device is not configured.

Actual results:

Rendered template looks like this:

~~~
(...)

... network ksdevice=bootif ks.device=bootif kssendmac ks.sendmac inst.ks.sendmac ip=192.168.250.81::192.168.250.1:255.255.255.0:ryan-blacher.example.local:vlan409:none nameserver=192.168.250.100 vlan=vlan409:bond0
~~~

Expected results:

~~
(...)
... network ksdevice=bootif ks.device=bootif kssendmac ks.sendmac inst.ks.sendmac ip=192.168.250.81::192.168.250.1:255.255.255.0:ryan-blacher.example.local:vlan409:none nameserver=192.168.250.100 bond=bond0:eth0,eth1:mode=active-backup,miimon=200 vlan=vlan409:bond0
~
~

Associated revisions

Revision b827e475 (diff)
Added by Joniel Pasqualetto 2 months ago

Fixes #32497 - allow template to properly manage vlan tag over bond interface

Allow the template kickstart_kernel_options to create the correct set of
options for dracut, in order to provision a server using a tagged VLAN over a bond
interface.

History

#1 Updated by Lukas Zapletal 3 months ago

  • Category set to Templates
  • Project changed from Templates to Foreman

#2 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8493 added

#3 Updated by The Foreman Bot 2 months ago

  • Fixed in Releases 3.0.0 added

#4 Updated by Joniel Pasqualetto 2 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Tomer Brisker about 2 months ago

  • Target version set to 2.5.1

#6 Updated by Tomer Brisker about 2 months ago

  • Fixed in Releases 2.5.1 added

Also available in: Atom PDF