Project

General

Profile

Refactor #32583

Tracker #29939: Improve setting definition DSL and move setting registry to memory

Mandatory setting type

Added by Ondřej Ezr 7 months ago. Updated 5 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Setting is guessing the type of the value based on it's default value, but it has it's drawbacks and it doesn't hurt to be specific about that.


Related issues

Is duplicate of Foreman - Refactor #32894: Add strong typing to Setting DSLClosed

History

#1 Updated by Ondřej Ezr 5 months ago

#2 Updated by Ondřej Ezr 5 months ago

  • Status changed from New to Duplicate

#3 Updated by Ondřej Ezr 5 months ago

Types are mandatory now. This was implemented directly #32894

Also available in: Atom PDF