Project

General

Profile

Bug #32623

katello:delete_orphaned_content fails on Katello 3.18 with "backend service pulp3: 503 Service Unavailable"

Added by Ian Ballou over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1959640

Description of problem:

After upgrading to Katello 3.18, the weekly cron "foreman-rake katello:publish_unpublished_repositories RAILS_ENV=production" from /etc/cron.d/katello fails. (And thus never executes against the rest of the smart proxies either). Pulp 3 is not in use on this system.

Version-Release number of selected component (if applicable):

Katello 3.18

How reproducible: Unsure

Steps to Reproduce:
1. Either wait for the weekly execution or invoke the cleanup manually: # foreman-rake katello:publish_unpublished_repositories RAILS_ENV=production

2. Check logs for backtrace (attachment

Actual results:

Logs report that the pulp3 service on Smart proxy Id 1 may be down

"[E|app|] Smart proxy with ID 1 may be down: There was an issue with the backend service pulp3: 503 Service Unavailable"

The cleanup never proceeds to clean-up other smart proxies, however, if you specify a single remote smart proxy with SMART_PROXY_ID= , it will succeed on that smart_proxy.

Expected results:

Clean-up job succeeds, and proceeds to clean up other smart proxies.

Associated revisions

Revision 63a1d5ba (diff)
Added by Ian Ballou over 1 year ago

Fixes #32623 - delete_orphaned_content fails if no Pulp 3 (#9373)

History

#1 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.4
  • Subject changed from publish_unpublished_repositories fails on Katello 3.18 with "backend service pulp3: 503 Service Unavailable" to publish_unpublished_repositories fails on Katello 3.18 with "backend service pulp3: 503 Service Unavailable"

#2 Updated by Ian Ballou over 1 year ago

  • Triaged changed from Yes to No
  • Target version deleted (Katello 3.18.4)
  • Subject changed from publish_unpublished_repositories fails on Katello 3.18 with "backend service pulp3: 503 Service Unavailable" to katello:delete_orphaned_content fails on Katello 3.18 with "backend service pulp3: 503 Service Unavailable"

The original BZ seems to be about delete_orphaned_content instead. Changing the title in the meantime.

#3 Updated by Ian Ballou over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.18.4

#4 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Ian Ballou
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9373 added

#5 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.2.0 added

#6 Updated by Anonymous over 1 year ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Jonathon Turel over 1 year ago

  • Target version changed from Katello 3.18.4 to Katello 3.18.3

Also available in: Atom PDF