Project

General

Profile

Bug #32626

Problems when creating a new repository with Chrome

Added by Richard Stempfl 12 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When using Chrome┬┤s feature to fill out login fields, i can not create a repository.
The Problem here is that Chrome fills out the passwordfield, if i delete it and try to save the repo i get a 404.
As workaround i can use a private session or save the repository with user/password and delete it afterwards.

A best practice workaround seems to be to set the autocomplete value for type password to "new-password"


Subtasks

Bug #32627: Empty username / password fails to create repository on chromeDuplicate

Related issues

Is duplicate of Katello - Bug #31949: Unable to create repositories in Pulp 3 mode with Firefox as the browser - username : This field may not be blank.Closed

Associated revisions

Revision 4c026a24 (diff)
Added by Bernhard Suttner 11 months ago

Fixes #32626 - Ignore empty upstream authentication

History

#1 Updated by Jonathon Turel 12 months ago

  • Target version set to Katello Recycle Bin
  • Status changed from New to Duplicate

This is addressed in 3.18.2 so upgrading should fix it!

#2 Updated by Jonathon Turel 12 months ago

  • Is duplicate of Bug #31949: Unable to create repositories in Pulp 3 mode with Firefox as the browser - username : This field may not be blank. added

#3 Updated by Jonathon Turel 12 months ago

  • Triaged changed from No to Yes

#4 Updated by Jonathon Turel 12 months ago

  • Status changed from Duplicate to Closed

#5 Updated by Richard Stempfl 12 months ago

Sadly it is katello-3.18.2-1.el7.noarch.

I could not choose this version in the menu.

#6 Updated by Richard Stempfl 12 months ago

  • Assignee set to Jonathon Turel

#7 Updated by Jonathon Turel 12 months ago

  • Triaged changed from Yes to No
  • Target version deleted (Katello Recycle Bin)
  • Assignee deleted (Jonathon Turel)
  • Status changed from Closed to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9370 added

#8 Updated by Chris Roberts 12 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.2.0

#9 Updated by The Foreman Bot 11 months ago

  • Fixed in Releases Katello 4.2.0 added

#10 Updated by Anonymous 11 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF