Project

General

Profile

Feature #32686

Update fog-google to a Ruby 3 compatible version

Added by Ewoud Kohl van Wijngaarden over 1 year ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - GCE
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

The current version of fog-google is incompatible with Ruby 3. A newer version is needed.


Related issues

Blocks Foreman - Tracker #32684: Ruby 3.0 supportNew

Associated revisions

Revision b797b977 (diff)
Added by Evgeni Golov 4 months ago

Fixes #32686 - use fog-google 1.14+, compatible with Ruby 3.0

fog-google 1.13 started announcing 3.0 compatibility in the gem spec,
but 1.14 contains bug fixes to actually make it work

Revision f8ba14cb (diff)
Added by Evgeni Golov 4 months ago

Refs #32686 - relax fog-core pin, we support newer fog-google now

History

#1 Updated by Ewoud Kohl van Wijngaarden over 1 year ago

#2 Updated by Ewoud Kohl van Wijngaarden over 1 year ago

#3 Updated by Ewoud Kohl van Wijngaarden over 1 year ago

#4 Updated by The Foreman Bot 4 months ago

  • Assignee set to Evgeni Golov
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9226 added

#5 Updated by The Foreman Bot 4 months ago

  • Fixed in Releases 3.4.0 added

#6 Updated by Evgeni Golov 4 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman/pull/9240 added

#8 Updated by Ewoud Kohl van Wijngaarden about 1 month ago

  • Category set to Compute resources - GCE

Also available in: Atom PDF