Project

General

Profile

Bug #32703

hammer user list --help has invalid --order example

Added by Tomer Brisker 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Low
Category:
API
Target version:
-
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1881668

Description of problem:
hammer user list --help shows:

..
--order ORDER Sort field and order, eg. ‘id DESC’
..

There are two errors in the example:

1) quote marks cant be used in a real example:

hammer> user list --order ‘id DESC’
Error: Too many arguments.

See: ' user list --help'.
hammer>

2) Even with proper quote marks, it does not work:

hammer> user list --order "id DESC"
400 Bad Request
the field 'id' in the order statement is not valid field for search
hammer>

(since also WebUI disallows searching by ID of user).

Version-Release number of selected component (if applicable):
Satellite 6.7.2
tfm-rubygem-hammer_cli-0.19.2.1-1.el7sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. hammer user list --help

Actual results:
..
--order ORDER Sort field and order, eg. ‘id DESC’
..

Expected results:
..
--order ORDER Sort field and order, eg. "login DESC"
..

Additional info:

Associated revisions

Revision 5e068c87 (diff)
Added by Adi Abramovitch 5 months ago

Fixes #32703 - fix invlid --order example

History

#1 Updated by Tomer Brisker 5 months ago

  • Difficulty set to trivial
  • Category changed from 19 to API

#2 Updated by Adi Abramovitch 5 months ago

  • Assignee set to Adi Abramovitch

#3 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8579 added

#4 Updated by The Foreman Bot 5 months ago

  • Fixed in Releases 3.0.0 added

#5 Updated by Adi Abramovitch 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF