Project

General

Profile

Actions

Feature #32769

closed

Associate a VM via API to a compute resource

Added by Dominik Matoulek over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Compute resources
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1774104

Proposed title of this feature request
Associate a VM via API or Hammer to a compute resource

What is the nature and description of the request?
Currently it needs to be done for each VM manually via Webui or for all VMs:
Infrastructure -> compute resources -> choose compute_resource -> Virtual Machines -> find desired vm -> hover over "Associate VM" button in the top right corner

Why does the user need this?
- Does not want to associate all VMs only certain VMs and currently this is not possible outside of the Webui.
- For automation

How would the user like to achieve this? (List the functional
requirements here)
Hammer or API call for:
~~
https://foreman-server/compute_resources/compute_resource_id/vms/instance_uuid/associate.
~~


Related issues 1 (0 open1 closed)

Related to Hammer CLI - Feature #33047: Associate a single VM via hammer to a compute resourceClosedAdi AbramovitchActions
Actions #1

Updated by Adi Abramovitch over 2 years ago

  • Subject changed from Associate a VM via API or hammer to a compute resource to Associate a VM via API to a compute resource
  • Category deleted (19)
Actions #2

Updated by Adi Abramovitch over 2 years ago

Dominik Matoulek wrote:

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1774104

Proposed title of this feature request
Associate a VM via API or Hammer to a compute resource

What is the nature and description of the request?
Currently it needs to be done for each VM manually via Webui or for all VMs:
Infrastructure -> compute resources -> choose compute_resource -> Virtual Machines -> find desired vm -> hover over "Associate VM" button in the top right corner

Why does the user need this?
- Does not want to associate all VMs only certain VMs and currently this is not possible outside of the Webui.
- For automation

How would the user like to achieve this? (List the functional
requirements here)
Hammer or API call for:
~~
https://foreman-server/compute_resources/compute_resource_id/vms/instance_uuid/associate.
~~

Actions #3

Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8677 added
Actions #4

Updated by yifat makias over 2 years ago

  • Is duplicate of Feature #33047: Associate a single VM via hammer to a compute resource added
Actions #5

Updated by yifat makias over 2 years ago

  • Status changed from Ready For Testing to Duplicate
Actions #6

Updated by yifat makias over 2 years ago

  • Bugzilla link changed from 1774104 to 1937470
Actions #7

Updated by The Foreman Bot over 2 years ago

  • Fixed in Releases 3.1.0 added
Actions #8

Updated by Ondřej Ezr over 2 years ago

  • Status changed from Duplicate to Closed
Actions #9

Updated by Ondřej Ezr over 2 years ago

  • Is duplicate of deleted (Feature #33047: Associate a single VM via hammer to a compute resource)
Actions #10

Updated by Ondřej Ezr over 2 years ago

  • Related to Feature #33047: Associate a single VM via hammer to a compute resource added
Actions #11

Updated by Amit Upadhye over 2 years ago

  • Category set to Compute resources
Actions

Also available in: Atom PDF