Project

General

Profile

Bug #32815

Disconnected satellite's subscription page missing the checkbox/select column

Added by Lucy Fu 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1947867

Description of problem:

After importing manifest in Disconnected satellite, the subscription page does not show the first column which has Checkbox/Select and ">" expand option. As a result it is also not possible to see all the subscriptions which are grouped together.

Version-Release number of selected component (if applicable):
Satellite 6.8

How reproducible:
100%

Steps to Reproduce:
1. Set the satellite to disconnected Mode:

Settings > Content > Disconnected mode > Yes

2. Create a new organization "disconnectorg" and select "disconnectorg" as org.

3. Import manifest which has different subscriptions - grouped by/together and individual

4. After importing check the subscription page - WEBUI > Content> Subscriptions>

Actual results:

First column which has Checkbox/Select and ">" is missing from the subscription page

Expected results:

The column should be visible and ">" should expand all the group by subscriptions

Additional info:

- hammer subscriptions list shows all the subscriptions

- If we try to add subscription in the activation key, it also shows all the subscriptions properly in available subscription list under "Add" tab. Means :

WEBUI > Content > Activation Key > Select Activation key > Subscription Tab > Add

This shows all the subscription available as per the manifest.

So the issue looks like only the WEBUI > Content> Subscriptions page.

Associated revisions

Revision eb8feb65 (diff)
Added by Lucy Fu 11 months ago

Fixes #32815 - Display checkbox/select column for grouped subscriptions (#9415)

History

#1 Updated by Justin Sherrill 11 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.2.0
  • Subject changed from Disconnected satellite's subscription page missing the checkbox/select column to Disconnected satellite's subscription page missing the checkbox/select column

#2 Updated by The Foreman Bot 11 months ago

  • Assignee set to Lucy Fu
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9415 added

#3 Updated by The Foreman Bot 11 months ago

  • Fixed in Releases Katello 4.2.0 added

#4 Updated by Lucy Fu 11 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF