Project

General

Profile

Feature #32851

Add parameter to provisioning templates to run attach --auto after registering

Added by Doug Forster 11 months ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
-
Target version:
Difficulty:
trivial
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Add support to run "subscription-manager attach --auto" after a host is registered with an Activation Key in the Provisioning scripts. These are maintained in the Foreman repo but I didn't see a great fit for them there. Figured this would be a better place to report.

The problem is we have Foreman provisioning hosts and a RH Satellite providing content. When the existing provisioning script runs it adds all the non-RH repos to the hosts. When "subscription-manager attach --auto" is run it correctly grabs the RedHat VM/virtual-datacenter license.

Here is the provisioning script:
https://github.com/theforeman/foreman/blob/develop/app/views/unattended/provisioning_templates/snippet/redhat_register.erb

Suggested edit add this to the header: #
  1. subscription_manager_auto_attach = 'false' Run attach --auto after registering. #

Add this just before the "subscription-manager repos --list" block at line 194:
<% if host_param_true?('subscription_manager_auto_attach', false) >
subscription-manager attach --auto
<
end %>


Related issues

Is duplicate of Foreman - Feature #32852: Add parameter to provisioning templates to run attach --auto after registeringClosed

History

#1 Updated by Doug Forster 11 months ago

  • Pull request https://github.com/theforeman/foreman/pull/8615 added

#2 Updated by Doug Forster 11 months ago

  • Status changed from New to Duplicate

#3 Updated by Jonathon Turel 11 months ago

  • Is duplicate of Feature #32852: Add parameter to provisioning templates to run attach --auto after registering added

#4 Updated by Jonathon Turel 11 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin

Also available in: Atom PDF