Project

General

Profile

Bug #32905

Use correct inverse association for kt_environment -> organization association

Added by Ondřej Ezr over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Lifecycle Environments
Target version:
Difficulty:
trivial
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Associated revisions

Revision 10ef8120 (diff)
Added by Ondřej Ezr over 1 year ago

Fixes #32905 - correct reverse association

We were accidently using reverse association environments, as there were
no failures caused by it, it got silently overlooked.

This needs to get fixed as the `environments` association goes away from
foreman core and this will cause katello not be able to start.

History

#1 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Ondřej Ezr
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9434 added

#2 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.2.0 added

#3 Updated by Ondřej Ezr over 1 year ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Chris Roberts over 1 year ago

  • Target version set to Katello 4.2.0

#5 Updated by Chris Roberts over 1 year ago

  • Triaged changed from No to Yes

Also available in: Atom PDF