Project

General

Profile

Bug #32921

DHCP next-server option is "false" when tftp-servername was not provided

Added by Lukas Zapletal about 1 month ago. Updated 29 days ago.

Status:
Closed
Priority:
Normal
Category:
TFTP
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

When installer option --foreman-proxy-tftp-servername is unset, smart proxy DHCP module renders next-server as "false". This is caused by expecting serverName is returned as nil, however, it looks like smart proxy can return empty string too.

Associated revisions

Revision 32181a11 (diff)
Added by Lukas Zapletal 29 days ago

Fixes #32921 - treat empty TFTP servername correctly

History

#1 Updated by Lukas Zapletal about 1 month ago

  • Triaged changed from No to Yes
  • Target version set to 2.5.2

Requesting backport to 2.5 and 2.4

#2 Updated by Lukas Zapletal about 1 month ago

  • Category changed from TFTP to TFTP
  • Project changed from Smart Proxy to Foreman

#3 Updated by The Foreman Bot about 1 month ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8635 added

#4 Updated by The Foreman Bot 29 days ago

  • Fixed in Releases 3.0.0 added

#5 Updated by Tomer Brisker 29 days ago

  • Fixed in Releases 2.5.2 added

#6 Updated by Lukas Zapletal 29 days ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF