Project

General

Profile

Bug #32965

Deleting repository shows success toast notification but repositories remain on the page

Added by Chris Roberts 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Description of problem:

The deletion of selected repositories on the Repositories tab spawns a task which runs asynchronously. I see the green toast notification however the selected repositories remain on the page and the page never refreshes. I only see them remove after manual refresh.

Version-Release number of selected component (if applicable):

6.10 / nightly

How reproducible:

100%

Steps to Reproduce:
1. go to product repositories page
2. select at least one repo
3. click "Remove Repositories" button

Actual results:

repos gets deleted but the page still shows them

Expected results:

repos disapper

Additional info:

In case the deletion fails I'm not notified in any way, the toast is always green since the task gets successfully created. If I remain on the page, I'd expect a new toast once the task fails.

Associated revisions

Revision e87c9331 (diff)
Added by Chris Roberts 10 months ago

Fixes #32965 - Have repo delete go directly to task instead of toast

History

#1 Updated by The Foreman Bot 10 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9449 added

#2 Updated by Jonathon Turel 10 months ago

  • Target version deleted (Katello 3.18.5)

#3 Updated by The Foreman Bot 10 months ago

  • Fixed in Releases Katello 4.2.0 added

#4 Updated by Chris Roberts 10 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by James Jeffers 10 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.2.0

Also available in: Atom PDF