Project

General

Profile

Bug #32994

Sync of content from an authenticated yum repository fails

Added by Partha Aji 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Based off
https://community.theforeman.org/t/katello-4-1-repo-sync-fails-for-repository-requiring-username-password/24331

Steps to Reproduce:
1. try to sync an image from an authenticated yum repository with username and password

Actual results:
the sync task ends in a warning state. With an error along
`NoMethodError: undefined method `username' for #<PulpRpmClient::RpmRpmRemoteResponse:0x000000002c4ee1f8>
`

Expected results:
no errors

The community link has a lot more details on this.


Related issues

Has duplicate Katello - Bug #33075: ContainerContainerRemoteResponse error when syncing container repoDuplicate

Associated revisions

Revision 27a2687d (diff)
Added by Justin Sherrill 6 months ago

Fixes #32994 - always refresh remote

we cannot reliably detect if a remote needs update due to
proxy auth and upstream auth information being removed from the api.
As a result there is not much we can do other than to always refresh it

History

#1 Updated by Partha Aji 6 months ago

  • Bugzilla link set to 1967604

#2 Updated by The Foreman Bot 6 months ago

  • Assignee set to Justin Sherrill
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9454 added

#3 Updated by James Jeffers 6 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.1.2

#4 Updated by James Jeffers 6 months ago

  • Has duplicate Bug #33075: ContainerContainerRemoteResponse error when syncing container repo added

#5 Updated by The Foreman Bot 6 months ago

  • Fixed in Releases Katello 4.3.0 added

#6 Updated by Justin Sherrill 6 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by The Foreman Bot 6 months ago

  • Pull request https://github.com/Katello/katello/pull/9492 added

Also available in: Atom PDF