Project

General

Profile

Bug #32997

Enabling a RH repo is not reflected in the list of enabled repos

Added by Andrew Dewar over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Associated revisions

Revision a28eb7bf (diff)
Added by Andrew Dewar over 1 year ago

Fixes #32997 - Enabling a repo not reflected in list (#9456)

History

#1 Updated by Samir Jha over 1 year ago

  • Subject changed from Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1975276 to Enabling a RH repo is not reflected in the list of enabled repos

#2 Updated by Andrew Dewar over 1 year ago

Description of problem:
Enabling some RH repositories on WebUI URI /redhat_repositories, when I click to add a repository, it does not appear in the right list of enabled repositories. The list just updates the counter to e.g. "NaN-NaN of 9" (I started with no repo enabled and added 9 repos), but the list below is empty.

Refreshing the page, I do see all the enabled repos, though.

Crucial point here is to check "Recommended Repositories". With this enabled, I can reproduce it. With that disabled, all works fine.

Version-Release number of selected component (if applicable):
Sat 6.10 spin 4
satellite-6.10.0-0.1.beta.el7sat.noarch
katello-4.1.0-0.6.rc2.el7sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. A new Sat6.10 with imported manifest
2. WebUI: Content -> Red Hat Repositories (which shows no enabled repo, now - so far good)
3. Click to "Recommended Repositories"
4. Unwrap some repo groups and enable some repo.
5. See what happens in "Enabled repositories" section.

Actual results:
5. Even after the spinner for the task to enable a repo is completed, the repo is not added/listed in "Enabled repositories" section. Just the stats like "NaN-NaN of 2" is updated.

Expected results:
List of enabled repos to be updated as well.

Additional info:
I don't see this happening in Sat6.9, so it sounds like a regression in user experience.

I do use Firefox 88.

#3 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9456 added

#4 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.2.0 added

#5 Updated by Andrew Dewar over 1 year ago

  • Status changed from Ready For Testing to Closed

#6 Updated by James Jeffers over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.2.0

Also available in: Atom PDF