Project

General

Profile

Bug #33000

Not possible to remove subscriptions from 'WebUI --> Content --> Subscriptions' page if the user doesn't have 'Setting' permissions."

Added by Lucy Fu over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1965968

Description of problem:
- Since Satellite 6.8 it's not possible to remove subscriptions from 'WebUI --> Content --> Subscriptions' page if the user doesn't have 'Setting' permissions. The checkbox using which you can select subscriptions is missing.

Version-Release number of selected component (if applicable):
- Satellite 6.8
- Satellite 6.9

How reproducible:
- Always

Steps to Reproduce:
- Create a role and assign 'Organization', 'Location' and 'Subscription' permissions. [without_setting1.png]
- Associate the role with a user. [without_setting2.png]
- Login as this user and navigate to 'Subscriptions' page. The checkboxes next to each subscription are missing. [without_setting3.png]
- Add 'Setting' permission to the role. [with_setting1.png]
- Login as the user and navigate to 'Subscriptions' page. The checkboxes are present and you can select subscriptions. [with_setting2.png]

Additional info:
- It was not necessary to have permissions from 'Setting' resource in Satellite 6.7. Is this expected?

Thanks in advance for your feedback.

Kind regards,
Jan

Associated revisions

Revision 0e11585c (diff)
Added by Lucy Fu over 1 year ago

Fixes #33000 - Display checkbox/select column for non-admin users

History

#1 Updated by The Foreman Bot over 1 year ago

  • Assignee set to Lucy Fu
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9455 added

#2 Updated by Jonathon Turel over 1 year ago

  • Subject changed from Since Satellite 6.8 it's not possible to remove subscriptions from 'WebUI --> Content --> Subscriptions' page if the user doesn't have 'Setting' permissions." to Not possible to remove subscriptions from 'WebUI --> Content --> Subscriptions' page if the user doesn't have 'Setting' permissions."

#3 Updated by James Jeffers over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.2.0

#4 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.2.0 added

#5 Updated by Lucy Fu over 1 year ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF