Project

General

Profile

Actions

Bug #33058

closed

Capsule sync failed after upgrade with missing repository type error.

Added by Justin Sherrill almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1978571

Description of problem: Capsule sync failed after upgrade with a missing repository type error.

Version-Release number of selected component (if applicable):
6.10 Snap7

How reproducible:
always

Steps to Reproduce:
1. Prepare the 6.9.z setup using the upgrade template.
2. Run the pulp migration.
3. Pulp migration and it completes successfully.
4. Run the upgrade from 6.9 to 6.10 snap7 and upgrade completed successfully with BZ#1967685
5- Prepare a 6.10 capsule setup and add that capsule with the upgraded satellite.
6- Assign the organization's life cycle environment and location to the capsule.
7- Run the capsule sync.
8- Capsule sync failed with "can not find repository type" error

Actual results:
Capsule sync failed with "can not find repository type" error

Expected results:
Capsule sync should be completed successfully.

Additional info:

Actions #1

Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Justin Sherrill
  • Pull request https://github.com/Katello/katello/pull/9478 added
Actions #2

Updated by James Jeffers over 2 years ago

  • Target version set to Katello 4.0.2
  • Triaged changed from No to Yes
Actions #3

Updated by James Jeffers over 2 years ago

  • Target version changed from Katello 4.0.2 to Katello 4.0.3
Actions #4

Updated by The Foreman Bot over 2 years ago

  • Fixed in Releases Katello 4.3.0 added
Actions #5

Updated by Justin Sherrill over 2 years ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF