Project

General

Profile

Bug #33075

ContainerContainerRemoteResponse error when syncing container repo

Added by Jonathon Turel 4 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

19:23:07 rails.1   | 2021-07-20T19:23:07 [E|bac|365ca55a] undefined method `username' for #<PulpContainerClient::ContainerContainerRemoteResponse:0x00007f3df3b387f0> (NoMethodError)
19:23:07 rails.1   |  365ca55a | /home/vagrant/katello/app/services/katello/pulp3/repository.rb:148:in `block in remote_needs_updates?'
19:23:07 rails.1   |  365ca55a | /home/vagrant/katello/app/services/katello/pulp3/repository.rb:148:in `any?'
19:23:07 rails.1   |  365ca55a | /home/vagrant/katello/app/services/katello/pulp3/repository.rb:148:in `remote_needs_updates?'
19:23:07 rails.1   |  365ca55a | /home/vagrant/katello/app/lib/actions/pulp3/repository/refresh_remote.rb:12:in `invoke_external_task'

Might be 3.14 related ie would be applicable to 6.10


Related issues

Is duplicate of Katello - Bug #32994: Sync of content from an authenticated yum repository failsClosed

History

#1 Updated by James Jeffers 4 months ago

  • Status changed from New to Duplicate

#2 Updated by James Jeffers 4 months ago

  • Is duplicate of Bug #32994: Sync of content from an authenticated yum repository fails added

#3 Updated by James Jeffers 4 months ago

  • Triaged changed from No to Yes

Also available in: Atom PDF