Project

General

Profile

Bug #33144

Installation source in hostgroup cannot be changed from "synced content" to local medium

Added by Fabrice Brimioulle 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

In a hostgroup where "synced content" is chosen as installation source it is not possible to change the source a to local medium. Trying to do so does not throw an error but when checking the value afterwards it still says "synced content".
The only currently possible workaround is to change the operating system, save the hostgroup and afterwards editting the hostgroup by changing the operating system back to the original value AND setting the correct medium.
This error only appears in this direction, changing from local medium to "synced content" works without a problem.

Steps to Reproduce:
1. Create a hostgroup
2. Choose "synced content" as installation source
3. Save the hostgroup
4. Edit the hostgroup and change the installation source to local medium
5. Save the hostgroup and check the value

Actual results:
Installation source still is "synced content"

Expected results:
Installation source is previously chosen medium

Associated revisions

Revision 0863618b (diff)
Added by Partha Aji 8 months ago

Fixes #33385,#33054,#33144 - Fixes host group inheritance (#9599)

Before the PR -

On create hostgroups page the inheritance hierachy behavior was different
between katello attribute like content_view/lce/content source etc vs
things like os and arch
For example if you create a child hostgroup and ppointed to a parent
with contnet view, you would see the cv automatically selected as the
default, instead of 'Inherit Content View' as os/arch fields behave.

More over if you had cv, lce, cs, arch filled in the parent hostgroup
and enabled operating system in the child the media section would not
get automatically populated (because the notion of parent_id was
missing)

After:

Both the above cases behave appropriately.

History

#1 Updated by Fabrice Brimioulle 10 months ago

  • Found in Releases Katello 3.18.4 added

#2 Updated by Ian Ballou 10 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.3.0

#3 Updated by Ian Ballou 10 months ago

  • Category set to Hosts

#4 Updated by The Foreman Bot 9 months ago

  • Assignee set to Partha Aji
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9599 added

#5 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases Katello 4.3.0 added

#6 Updated by Partha Aji 8 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by The Foreman Bot 8 months ago

  • Pull request https://github.com/Katello/katello/pull/9656 added

Also available in: Atom PDF