Project

General

Profile

Bug #33196

Cannot upgrade Foreman 2.4 to 2.5 on el8, due to switch from Ruby 2.5 to 2.7

Added by j s about 1 year ago. Updated about 1 year ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I think the Subject says it all.
Switching ruby module seems to require removal of all Ruiby 2.5 modules, which will completely remove foreman.

Is there a workable procedure to accomplish this switch & upgrade?

History

#1 Updated by Leos Stejskal about 1 year ago

Hi,
it would be worthy to post the issue with (with log output & steps how to reproduce it) at https://community.theforeman.org/ & discuss it there.

#2 Updated by j s about 1 year ago

Leos Stejskal wrote:

Hi,
it would be worthy to post the issue with (with log output & steps how to reproduce it) at https://community.theforeman.org/ & discuss it there.

Someone already tried that, 5 weeks ago:
https://community.theforeman.org/t/facing-difficulties-when-trying-to-upgrade-2-4-to-2-5/24145

Also available in: Atom PDF