Project

General

Profile

Bug #33197

Creating compute resource (VMware) with incorrect credentials claims successfull test connection

Added by Fabrice Brimioulle 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

How reproducible:

Steps to Reproduce:
1. Create a new compute resource in foreman (VMware) using incorrect login credentials.

2. Click on "Load Datacenters"

Actual results:
Datacenters are (of course) not loaded but foreman claims "Test connection successful".

Expected results:
The error "InvalidLogin: Cannot complete login due to an incorrect user name or password." is thrown.

Associated revisions

Revision cf6de107 (diff)
Added by Bernhard Suttner 3 months ago

Fixes #33197 - Show error message if credentials are wrong

History

#1 Updated by The Foreman Bot 3 months ago

  • Assignee set to Bernhard Suttner
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8703 added

#2 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 3.0.0 added

#3 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF