Project

General

Profile

Actions

Bug #33212

closed

foreman-rake katello:correct_repositories is failing to create the repositories.

Added by Ian Ballou almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Repositories
Target version:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1908101

The issue for Katello 4.0+ is that the actualy Pulp 3 repo creation step is being skipped because the Katello repository still has a RepositoryReference. We should add a force option to force repo creation in this case.

Actions #1

Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9534 added
Actions #2

Updated by Ian Ballou almost 3 years ago

  • Subject changed from foreman-rake katello:correct_repositories is failing to create the repositories. to foreman-rake katello:correct_repositories is failing to create the repositories.
  • Assignee changed from Justin Sherrill to Ian Ballou
Actions #3

Updated by Justin Sherrill almost 3 years ago

  • Target version set to Katello 4.1.3
  • Triaged changed from No to Yes
Actions #4

Updated by The Foreman Bot almost 3 years ago

  • Fixed in Releases Katello 4.3.0 added
Actions #5

Updated by Anonymous almost 3 years ago

  • Status changed from Ready For Testing to Closed
Actions #6

Updated by The Foreman Bot almost 3 years ago

  • Pull request https://github.com/Katello/katello/pull/9559 added
Actions

Also available in: Atom PDF