Project

General

Profile

Bug #33539

Undefined method error when calling Api::V2::SmartProxiesController#import_puppetclasses

Added by Nadja Heitmann 4 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

09:16:04 rails.1   | 2021-09-22T09:16:04 [I|app|036b295b] Started POST "/api/smart_proxies/1/import_puppetclasses" for 192.168.121.1 at 2021-09-22 09:16:04 +0000
09:16:04 rails.1   | 2021-09-22T09:16:04 [I|app|036b295b] Processing by Api::V2::SmartProxiesController#import_puppetclasses as JSON
09:16:04 rails.1   | 2021-09-22T09:16:04 [I|app|036b295b]   Parameters: {"apiv"=>"v2", "id"=>"1", "smart_proxy"=>{}}
09:16:04 rails.1   | 2021-09-22T09:16:04 [W|app|036b295b] Action failed
09:16:04 rails.1   | 2021-09-22T09:16:04 [I|app|036b295b] Backtrace for 'Action failed' error (NoMethodError): undefined method `fail_and_inform_about_plugin_for_import' for #<Api::V2::SmartProxiesController:0x00007fa0d95f2838>

Tested on current develop branch (fcd63a38456375144f15d174d8945e68615e0c1d)

Associated revisions

Revision 639f102a (diff)
Added by Nadja Heitmann 4 months ago

Fixes #33539 - use correct deprecation

This fixes Undefined method error for Api::V2::SmartProxiesController#import_puppetclasses
That is caused by a wrong deprecation method being called.

History

#1 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8788 added

#2 Updated by The Foreman Bot 4 months ago

  • Fixed in Releases 3.1.0 added

#3 Updated by Nadja Heitmann 4 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Amit Upadhye 2 months ago

  • Category set to API

#5 Updated by Ondřej Ezr 2 months ago

  • Fixed in Releases 3.0.2 added

Also available in: Atom PDF