Project

General

Profile

Bug #33573

Navigating to Admin, Organization, and selecting an organization gives 404

Added by Lucy Fu 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1982759

Description of problem:

In web UI, I navigated Administer > Organization and selecting an organization's name.

Error was displayed:
Oops, we're sorry but something went wrong 404 Not Found

Version-Release number of selected component (if applicable):
~]# rpm -q satellite
satellite-6.10.0-0.4.beta.el7sat.noarch
Snap 9.0

How reproducible:
Not very, does not happen if the org has no hosts. Happens repeatedly on orgs with one host

Steps to Reproduce:
1. Create some orgs
2. Create one content host in some of the orgs
3. navigate Administer > Organization and select the organization's names.

Actual results:
If the org has a host:
Oops, we're sorry but something went wrong 404 Not Found

Expected results:
no errors

Associated revisions

Revision 6f9310a4 (diff)
Added by Lucy Fu 8 months ago

Fixes #33573 - catch RestClient::NotFound in UpstreamConsumer

History

#1 Updated by The Foreman Bot 8 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9674 added

#2 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases Katello 4.3.0 added

#3 Updated by Lucy Fu 8 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by James Jeffers 8 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.3.0
  • Subject changed from Navigating to Admin, Organization, and selecting an organization gives 404 to Navigating to Admin, Organization, and selecting an organization gives 404

Also available in: Atom PDF