Project

General

Profile

Bug #33671

don't warn about apipie cache when using "rake config"

Added by Evgeni Golov 4 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Rake tasks
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

foreman-rake config … is often used in automation as an API to fetch/set config options. However, this sometimes includes the ugly "API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache." warning, confusing the app trying to fetch the config.

lets hide the warning when in "config" mode too.


Related issues

Is duplicate of Foreman - Bug #33369: Print warnings subceptible to show up in a console session to stderrNew

Associated revisions

Revision 701fff0b (diff)
Added by Evgeni Golov 3 months ago

Fixes #33671 - hide apipie warning in config

before this patch:

  1. foreman-rake config -- -k use_shortname_for_vms
    API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache.
    false

after this patch:

  1. foreman-rake config -- -k use_shortname_for_vms
    false

History

#1 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8829 added

#2 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman/pull/8830 added

#3 Updated by Ewoud Kohl van Wijngaarden 4 months ago

  • Is duplicate of Bug #33369: Print warnings subceptible to show up in a console session to stderr added

#4 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 3.1.0 added

#5 Updated by Evgeni Golov 3 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Amit Upadhye 2 months ago

  • Category set to Rake tasks

Also available in: Atom PDF