Project

General

Profile

Bug #33676

Packages from AppStream variant are invisible

Added by Lukas Zapletal 7 months ago. Updated 6 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello,

when you sync CentOS 8 (or Stream) BaseOS repo, Pulp3 (not Pulp2) automatically adds "AppStream" variant. Meaning, packages from AppStream repo are automatically synced and made available in the BaseOS repository too. If you open up synced directory, there is a subdirectory named "AppStream/Packages" with all packages and metadata and .repoid also contains the variant. Anaconda automatically

Problem is, when I visit the repository in Katello, I am unable to see any AppStream packages. For example vim-enhanced is from this repository, but it is not available.

I do not understand how this is supposed to work, packages are obviously synchronized, published thus in Pulp database, however, users cannot work with them.

History

#1 Updated by Ryan Verdile 7 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.3.0

#2 Updated by Ian Ballou 7 months ago

  • Status changed from New to Need more information

Lukas, when you tried this out, do you remember your Pulp 3 versions? Specifically pulpcore and pulp-rpm.

I just synced CentOS 8 BaseOS (http://mirror.centos.org/centos/8/BaseOS/x86_64/os) and my published AppStream packages are all downloadable. I tried vim-enhanced like you mentioned at https://centos7-katello-devel.example.com/pulp/content/Default_Organization/Library/custom/My_Product/CentOS_8_BaseOS/AppStream/Packages/vim-enhanced-8.0.1763-15.el8.x86_64.rpm and was able to download it.

Is that what you were referring to? I wonder if you hit a transient bug or perhaps an issue with a prior Pulp 3 version.

#3 Updated by Chris Roberts 6 months ago

  • Target version changed from Katello 4.3.0 to Katello 4.4.0

#4 Updated by Ian Ballou 6 months ago

The issue may be that the AppStream packages are not indexed into Katello even though they are downloaded. I need to investigate this.

#5 Updated by Ian Ballou 6 months ago

  • Target version changed from Katello 4.4.0 to Katello Backlog
  • Status changed from Need more information to New

The Pulp team responded to me with this:

"... in this case Appstream is a sub repo and we do not support managing those. Bits are in database but the repo is not available to be managed".

As this is the case, I would recommend filing a feature request with Pulp if anyone reading this is interested enough: https://pulp.plan.io/

I will be putting this on the backlog since it's expected behavior but there is potential for improvement.

#6 Updated by Lukas Zapletal 6 months ago

Ian, sorry I missed your comment in the sea of redmine update notifications.

I think I tested on 6.10 snap, but not entirely sure.

Thanks for keepin this open as a possible improvement. We should probably document that. I will create a doco BZ for that.

#7 Updated by Lukas Zapletal 6 months ago

Created: https://bugzilla.redhat.com/show_bug.cgi?id=2027484

If you could elaborate or correct my statements, I'd appreciate that. Thanks.

Also available in: Atom PDF