Project

General

Profile

Bug #3370

All subcommands associated with "organization" fail

Added by Dominic Cleal over 6 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Foreman commands (obsolete)
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

All subcommands associated with hammer organization fail with message "The server does not support such operation."

[root@rhel6b ~]# hammer -v organization list
[ INFO 2013-10-18 20:24:36 Init] Configuration from the file /etc/foreman/cli_config.yml has been loaded
[ INFO 2013-10-18 20:24:36 Init] Extension module hammer_cli_foreman loaded
[ INFO 2013-10-18 20:24:36 HammerCLI::MainCommand] Called with options: {"verbose"=>true}
[ INFO 2013-10-18 20:24:36 HammerCLIForeman::Organization] Called with options: {}
[ INFO 2013-10-18 20:24:36 HammerCLIForeman::Organization::ListCommand] Called with options: {}
The server does not support such operation.

production.log shows a weird request:

Started GET "/api/organization_id" for ::1 at 2013-10-18 20:25:05 +0000
Processing by Api::V1::HomeController#route_error as JSON
  Parameters: {"other"=>"organization_id", "home"=>{}}
Authorized user admin(Admin User)
  Rendered api/v1/errors/route_error.json.rabl (0.3ms)
Completed 404 Not Found in 16ms (Views: 0.9ms | ActiveRecord: 5.8ms)

foreman-1.3.0-1.el6.noarch
rubygem-hammer_cli-0.0.7-1.el6.noarch
rubygem-hammer_cli_foreman-0.0.7-1.el6.noarch

(https://bugzilla.redhat.com/show_bug.cgi?id=1021039)

History

#1 Updated by Dominic Cleal over 6 years ago

  • Description updated (diff)

#2 Updated by Martin Bacovsky over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Martin Bacovsky
  • Target version set to 1.15.0
  • Legacy Backlogs Release (now unused) set to 1

This is caused by foreman_api that was generated with buggy version of apipie. Fixing the deps.

#3 Updated by Martin Bacovsky over 6 years ago

  • Status changed from Assigned to Ready For Testing

#4 Updated by Martin Bacovsky over 6 years ago

  • Status changed from Ready For Testing to Resolved

Also available in: Atom PDF