Project

General

Profile

Bug #33897

Mismatch report fails with 'uninitialized constant Environment'

Added by Ewoud Kohl van Wijngaarden 3 months ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Organizations and Locations
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

I have foreman_puppet 1.0.4 installed and yet it fails with:

2021-11-10T12:14:02 [I|app|b1cbc6a3] Started GET "/locations/mismatches" for MY_IP at 2021-11-10 12:14:02 +0100
2021-11-10T12:14:02 [I|app|b1cbc6a3] Processing by LocationsController#mismatches as HTML
2021-11-10T12:14:02 [W|app|b1cbc6a3] uninitialized constant Environment
2021-11-10T12:14:02 [I|app|b1cbc6a3] Backtrace for 'uninitialized constant Environment' error (NameError): uninitialized constant Environment
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/inflector/methods.rb:282:in `const_get'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/inflector/methods.rb:282:in `block in constantize'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/inflector/methods.rb:280:in `each'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/inflector/methods.rb:280:in `inject'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/inflector/methods.rb:280:in `constantize'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/core_ext/string/inflections.rb:68:in `constantize'
 b1cbc6a3 | /usr/share/foreman/app/services/tax_host.rb:32:in `block in selected_ids'
 b1cbc6a3 | /usr/share/foreman/app/services/tax_host.rb:31:in `each'
 b1cbc6a3 | /usr/share/foreman/app/services/tax_host.rb:31:in `selected_ids'
 b1cbc6a3 | /usr/share/foreman/app/services/tax_host.rb:59:in `selected_or_inherited_ids'
 b1cbc6a3 | /usr/share/foreman/app/services/tax_host.rb:75:in `block in need_to_be_selected_ids'
 b1cbc6a3 | /usr/share/foreman/app/services/tax_host.rb:71:in `map'
 b1cbc6a3 | /usr/share/foreman/app/services/tax_host.rb:71:in `need_to_be_selected_ids'
 b1cbc6a3 | /usr/share/foreman/app/services/tax_host.rb:109:in `mismatches'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:224:in `mismatches'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:126:in `block in all_mismatcheds'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activerecord-6.0.3.7/lib/active_record/relation/delegation.rb:87:in `each'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activerecord-6.0.3.7/lib/active_record/relation/delegation.rb:87:in `each'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:126:in `map'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:126:in `all_mismatcheds'
 b1cbc6a3 | /usr/share/foreman/app/controllers/concerns/foreman/controller/taxonomies_controller.rb:118:in `block in mismatches'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:73:in `block in no_taxonomy_scope'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:80:in `block (2 levels) in as_taxonomy'
 b1cbc6a3 | /usr/share/foreman/app/models/concerns/foreman/thread_session.rb:195:in `as_location'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:79:in `block in as_taxonomy'
 b1cbc6a3 | /usr/share/foreman/app/models/concerns/foreman/thread_session.rb:154:in `as_org'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:78:in `as_taxonomy'
 b1cbc6a3 | /usr/share/foreman/app/models/taxonomy.rb:72:in `no_taxonomy_scope'
 b1cbc6a3 | /usr/share/foreman/app/controllers/concerns/foreman/controller/taxonomies_controller.rb:117:in `mismatches'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_controller/metal/basic_implicit_render.rb:6:in `send_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/abstract_controller/base.rb:195:in `process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_controller/metal/rendering.rb:30:in `process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/abstract_controller/callbacks.rb:42:in `block in process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/callbacks.rb:112:in `block in run_callbacks'
 b1cbc6a3 | /usr/share/foreman/app/controllers/concerns/foreman/controller/timezone.rb:10:in `set_timezone'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/callbacks.rb:121:in `block in run_callbacks'
 b1cbc6a3 | /usr/share/foreman/app/models/concerns/foreman/thread_session.rb:32:in `clear_thread'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/callbacks.rb:121:in `block in run_callbacks'
 b1cbc6a3 | /usr/share/foreman/app/controllers/concerns/foreman/controller/topbar_sweeper.rb:12:in `set_topbar_sweeper_controller'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/callbacks.rb:121:in `block in run_callbacks'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/audited-4.9.0/lib/audited/sweeper.rb:14:in `around'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/callbacks.rb:121:in `block in run_callbacks'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/audited-4.9.0/lib/audited/sweeper.rb:14:in `around'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/callbacks.rb:121:in `block in run_callbacks'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/callbacks.rb:139:in `run_callbacks'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/abstract_controller/callbacks.rb:41:in `process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_controller/metal/rescue.rb:22:in `process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_controller/metal/instrumentation.rb:33:in `block in process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/notifications.rb:180:in `block in instrument'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/notifications/instrumenter.rb:24:in `instrument'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/notifications.rb:180:in `instrument'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_controller/metal/instrumentation.rb:32:in `process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_controller/metal/params_wrapper.rb:245:in `process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activerecord-6.0.3.7/lib/active_record/railties/controller_runtime.rb:27:in `process_action'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/abstract_controller/base.rb:136:in `process'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionview-6.0.3.7/lib/action_view/rendering.rb:39:in `process'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_controller/metal.rb:190:in `dispatch'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_controller/metal.rb:254:in `dispatch'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/routing/route_set.rb:50:in `dispatch'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/routing/route_set.rb:33:in `serve'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/journey/router.rb:49:in `block in serve'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/journey/router.rb:32:in `each'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/journey/router.rb:32:in `serve'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/routing/route_set.rb:834:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-dsl-2.4.0/lib/apipie_dsl/static_dispatcher.rb:67:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-rails-0.5.17/lib/apipie/static_dispatcher.rb:66:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-rails-0.5.17/lib/apipie/extractor/recorder.rb:137:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/static.rb:126:in `call'
 b1cbc6a3 | /usr/share/foreman/lib/foreman/middleware/telemetry.rb:10:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/apipie-rails-0.5.17/lib/apipie/middleware/checksum_in_headers.rb:27:in `call'
 b1cbc6a3 | /usr/share/foreman/lib/foreman/middleware/catch_json_parse_errors.rb:9:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/tempfile_reaper.rb:15:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/etag.rb:27:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/conditional_get.rb:27:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/head.rb:12:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/http/content_security_policy.rb:18:in `call'
 b1cbc6a3 | /usr/share/foreman/lib/foreman/middleware/logging_context_session.rb:22:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/session/abstract/id.rb:266:in `context'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/session/abstract/id.rb:260:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/cookies.rb:648:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/callbacks.rb:27:in `block in call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/callbacks.rb:101:in `run_callbacks'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/callbacks.rb:26:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/actionable_exceptions.rb:18:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/debug_exceptions.rb:32:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/show_exceptions.rb:33:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/railties-6.0.3.7/lib/rails/rack/logger.rb:37:in `call_app'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/railties-6.0.3.7/lib/rails/rack/logger.rb:28:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/sprockets-rails-3.2.1/lib/sprockets/rails/quiet_assets.rb:13:in `call'
 b1cbc6a3 | /usr/share/foreman/lib/foreman/middleware/logging_context_request.rb:11:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/remote_ip.rb:81:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/request_id.rb:27:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/method_override.rb:24:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/runtime.rb:22:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/activesupport-6.0.3.7/lib/active_support/cache/strategy/local_cache_middleware.rb:29:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/executor.rb:14:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/static.rb:126:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/sendfile.rb:110:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/actionpack-6.0.3.7/lib/action_dispatch/middleware/host_authorization.rb:76:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/secure_headers-6.3.0/lib/secure_headers/middleware.rb:11:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/railties-6.0.3.7/lib/rails/engine.rb:527:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/railties-6.0.3.7/lib/rails/railtie.rb:190:in `public_send'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/railties-6.0.3.7/lib/rails/railtie.rb:190:in `method_missing'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/urlmap.rb:74:in `block in call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/urlmap.rb:58:in `each'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/rack-2.2.3/lib/rack/urlmap.rb:58:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/puma-5.3.2/lib/puma/configuration.rb:249:in `call'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/puma-5.3.2/lib/puma/request.rb:77:in `block in handle_request'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/puma-5.3.2/lib/puma/thread_pool.rb:338:in `with_force_shutdown'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/puma-5.3.2/lib/puma/request.rb:76:in `handle_request'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/puma-5.3.2/lib/puma/server.rb:438:in `process_client'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/puma-5.3.2/lib/puma/thread_pool.rb:145:in `block in spawn_thread'
 b1cbc6a3 | /opt/theforeman/tfm/root/usr/share/gems/gems/logging-2.3.0/lib/logging/diagnostic_context.rb:474:in `block in create_with_logging_context'
2021-11-10T12:14:02 [I|app|b1cbc6a3]   Rendering common/500.html.erb within layouts/application
2021-11-10T12:14:02 [I|app|b1cbc6a3]   Rendered common/500.html.erb within layouts/application (Duration: 9.1ms | Allocations: 5253)
2021-11-10T12:14:02 [I|app|b1cbc6a3]   Rendered layouts/_application_content.html.erb (Duration: 6.6ms | Allocations: 4720)
2021-11-10T12:14:02 [I|app|b1cbc6a3]   Rendering layouts/base.html.erb
2021-11-10T12:14:02 [I|app|b1cbc6a3]   Rendered layouts/base.html.erb (Duration: 10.9ms | Allocations: 6028)
2021-11-10T12:14:02 [I|app|b1cbc6a3] Completed 500 Internal Server Error in 204ms (Views: 35.3ms | ActiveRecord: 37.1ms | Allocations: 43182)

Associated revisions

Revision 96a6076f (diff)
Added by Leos Stejskal about 2 months ago

Fixes #33897 - Puppet Environment in taxonomy ignore_types

History

#1 Updated by Ondřej Ezr 2 months ago

OH, now I see.
This is not in code because this is caused by some Location having set Environments to all and that means it is in the ignore list and there was no migration removing it.

#2 Updated by The Foreman Bot about 2 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/8962 added

#3 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases 3.2.0 added

#4 Updated by Leos Stejskal about 2 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Amit Upadhye about 2 months ago

  • Fixed in Releases 3.1.0 added

#6 Updated by Amit Upadhye about 2 months ago

  • Fixed in Releases deleted (3.2.0)

#7 Updated by Amit Upadhye 2 days ago

Ewoud Kohl van Wijngaarden wrote:

I have foreman_puppet 1.0.4 installed and yet it fails with:
[...]

The fix is for purge:puppet task which is not there in 3.0. If we dont want purge:puppet task in 3.0 then this can be skipped in 3.0.2.

#8 Updated by Ewoud Kohl van Wijngaarden 1 day ago

The fix in the git commit does not fix the problem in this issue. I think we should clone this issue and then reword it so it covers the git commit. Then keep the original report in this issue open.

Also available in: Atom PDF